2

A home brewing group I am with has a Grainfather Glycol Chiller.

It has been working fine until yesterday. We turned it on and we had an issue. The pump is working and circulating but the chiller is not. We have checked the connections and made sure we had enough glycol, etc. Yet the chiller doesn't work. We had a batch on a couple of weeks ago and it was working fine.

We thought about cleaning the connectors, which we'll look at this weekend. Also thought about overriding the chiller to see if that forces the chiller to act. Even if it doesn't solve the problem long term it may help to narrow down the cause.

I was wondering if anyone had any similar experience or ideas on what may be causing the issue and what their solution was.

We haven't contacted Grainfather yet but we are based in the UK so I suspect the response won't be the fastest right now.

  • I once forgot to plug in the controller cable from the chiller to the backside of the conical fermenter (I assume you are using one as well) - did you check that? Just to be sure. – RSeidelsohn Jun 29 at 19:13
  • Yes we are using the fermenter and we checked that. Did that mistake once before :P We did get a response from Grainfather requesting for some serial numbers. That is far as we got with them so far. – LemonJeBoum Jul 1 at 16:20
  • So, for anyone interested. We haven't resolved the issue yet but Grainfather have said they are moving it onto their technical team. – LemonJeBoum yesterday

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.